Resolved
Incident Report for MyCashflow
Postmortem

The root issue affecting the performance of MyCashflow stores has also been identified, and we will take additional measures to ensure similar issues are prevented in the future.

Posted Jan 08, 2025 - 13:33 EET

Resolved
Between January 2, 2025, and January 5, 2025, there were brief service interruptions lasting a few minutes affecting the performance of some MyCashflow stores. Based on our investigation, these interruptions were caused by momentary traffic spikes targeting the stores, with the traffic predominantly originating from China.

Since the majority of the traffic has been identified as harmful, we have implemented preventive measures by restricting traffic originating from China. Given the limited number of legitimate orders, the effect on merchants is expected to be minimal. The restriction will remain in effect until further notice.
Posted Jan 05, 2025 - 01:00 EET