Investigating

Incident Report for MyCashflow

Resolved

This incident has been resolved.
Posted May 12, 2023 - 16:19 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 16:09 EEST

Update

We are continuing to investigate this issue.
Posted May 12, 2023 - 16:09 EEST

Investigating

We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted May 12, 2023 - 16:05 EEST
This incident affected: MyCashflow Stores.