Major Outage

Incident Report for MyCashflow

Monitoring

The situation is gradually normalizing, and stores are becoming accessible. Mitigation measures implemented by our data center partner on the load balancers have effectively stabilized the traffic. We continue to monitor the situation closely to ensure full stability.
Posted Mar 24, 2026 - 10:57 EET

Identified

The service is temporarily unavailable due to a DDoS attack. We are currently experiencing a denial-of-service attack, which is preventing access to the service. We are taking immediate action to resolve the situation.
Posted Mar 24, 2026 - 08:50 EET

Investigating

We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Mar 24, 2026 - 06:23 EET
This incident affects: MyCashflow Stores.