Major Outage

Incident Report for MyCashflow

Resolved

We identified and fixed an issue on our file servers that caused the shops to be unresponsive. The system is now back in working order.
Posted Nov 16, 2024 - 16:30 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2024 - 16:05 EET

Investigating

We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Nov 16, 2024 - 15:09 EET
This incident affected: MyCashflow Stores.