Investigating
Incident Report for MyCashflow
Postmortem

Summary: The service experienced a spike of unexpected traffic causing partial outage.

Resolution: The immediate action taken was to identify the source of the traffic spike and block the incoming traffic from this source to stabilize the service.

Next Steps: We are investigating the feasibility of implementing rate limiting on traffic from individual sources. Going forward, we will implement traffic restrictions to prevent similar incidents from occurring again.

Posted Apr 04, 2024 - 14:26 EEST

Resolved
We identified and fixed an issue that was causing errors or affecting the performance of MyCashflow stores. The system is now back in working order.
Posted Mar 25, 2024 - 13:29 EET
Monitoring
We have deployed a new software update to fix an issue that was causing errors or affecting the performance of MyCashflow stores. We will be monitoring the situation. Follow this page for further updates.
Posted Mar 25, 2024 - 12:54 EET
Investigating
We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Mar 25, 2024 - 12:42 EET
This incident affected: MyCashflow Stores.