Investigating

Incident Report for MyCashflow

Resolved

We identified and fixed an issue that was causing errors or affecting the performance of MyCashflow stores. The system is now back in working order.
Posted Mar 08, 2023 - 12:03 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2023 - 11:23 EET

Investigating

We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Mar 08, 2023 - 11:23 EET
This incident affected: MyCashflow Stores.