Investigating
Incident Report for MyCashflow
Postmortem

Summary: A hardware failure on one of the database servers caused a critical service outage affecting part of our customers. The faulty hardware prevented the server from being restored to operational status, necessitating a full database migration to a new server. The migration was delayed due to compatibility issues between the older and the newer hardware.

Resolution: The affected databases were migrated to a new server, and the compatibility issues were addressed to restore service.

Next Steps: We have already improved our server hardware rotation to minimize hardware failures. We also identified the possible compatibility issues which enable faster service restoration in case of future incidents.

Posted Sep 02, 2024 - 17:12 EEST

Resolved
We identified and fixed an hardware issue that was affecting the availability of some of the MyCashflow stores. The system is now back in working order.
Posted Sep 02, 2024 - 17:11 EEST
Monitoring
We have managed to resolve the issue that was causing errors or affecting the performance of MyCashflow stores. We will be monitoring the situation. Follow this page for further updates.
Posted Sep 02, 2024 - 15:50 EEST
Update
A significant portion of the stores has now been successfully restored to normal operation. We are working to bring the remaining stores back online as soon as possible, and the restoration process is progressing.

Follow this page for further updates on the situation.
Posted Sep 02, 2024 - 15:28 EEST
Update
We are currently working in co-operation with the service provider on restoring normal operations in all the stores that have been affected by the outage in service.

Follow this page for further updates on the situation.
Posted Sep 02, 2024 - 15:20 EEST
Update
We are currently fixing the issue in co-operation with the service provider and have already managed to restore normal operations in some of the MyCashflow online stores affected.

Follow this page for further updates on the situation.
Posted Sep 02, 2024 - 14:48 EEST
Identified
We have identified the issue that has been causing errors or affecting the performance of some of the MyCashflow stores, and are currently working on a fix to resolve the situation.

The issue is caused by server disruptions, and we are working with the service provider to resolve it.

Follow this page for further updates on the situation.
Posted Sep 02, 2024 - 14:23 EEST
Investigating
We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Sep 02, 2024 - 13:53 EEST
This incident affected: MyCashflow Stores.