Investigating
Incident Report for MyCashflow
Postmortem

Summary: The service experienced a complete outage caused by a configuration error that allowed more concurrent traffic to individual servers than one server could handle, leading to memory exhaustion.

Resolution: We temporarily restricted traffic and restarted the affected servers to resolve the incident.

Next Steps: We have adjusted the server configurations to allow a more appropriate level of concurrent traffic. This adjustment prevents server crashes by enabling us to limit traffic under excessive load more effectively, thereby improving our control over similar situations in the future.

Posted Apr 04, 2024 - 15:32 EEST

Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 18:07 EEST
Update
We are continuing to monitor for any further issues.
Posted Apr 03, 2024 - 17:19 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2024 - 17:19 EEST
Update
We are continuing to investigate this issue.
Posted Apr 03, 2024 - 17:06 EEST
Investigating
We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Apr 03, 2024 - 16:55 EEST
This incident affected: MyCashflow Stores.