Major Outage
Incident Report for MyCashflow
Resolved
This incident has been resolved.
Posted Nov 24, 2024 - 11:30 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2024 - 11:18 EET
Investigating
We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Nov 24, 2024 - 11:06 EET
This incident affected: MyCashflow Stores.