Major Outage
Incident Report for MyCashflow
Postmortem

Summary:
On February 3, 2025, there were two brief service interruptions, one shortly after 20:00 and another before 22:00, each lasting a few minutes. These were caused by a sudden surge in requests targeting a single store, with traffic distributed across a large number of countries.

Immediate resolution:
During the traffic spike, our web servers became unresponsive but recovered automatically once the load subsided.

Next steps:
We are investigating ways to limit the amount of traffic directed at a single store to prevent similar incidents from affecting other stores in the future.

Posted Feb 05, 2025 - 16:07 EET

Resolved
This incident has been resolved.
Posted Feb 03, 2025 - 20:53 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2025 - 20:20 EET
Update
We are continuing to investigate this issue.
Posted Feb 03, 2025 - 20:13 EET
Investigating
We are investigating an issue that is causing errors or affecting the performance of MyCashflow stores. Follow this page for further updates on the situation.
Posted Feb 03, 2025 - 20:13 EET
This incident affected: MyCashflow Stores.