A technical error in the Postmark messaging system

Incident Report for MyCashflow

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 12:33 EET

Update

We are continuing to monitor for any further issues.
Posted Mar 24, 2025 - 09:45 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 09:45 EET

Investigating

A technical error has been detected in the Postmark messaging system, affecting outgoing order-related emails from the store, such as order confirmations and notifications.
Posted Mar 24, 2025 - 09:29 EET
This incident affected: Third-party services.